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• Debugger Features

• Why Use Debugging over CFDUMP, etc.

• Tips and Traps

• Learning More, FAQs, etc.



About Charlie Arehart
• Independent consultant since April 2006

• 11 yrs CF experience (26 in Enterprise IT)

– Member, Adobe Community Experts

– Certified Adv CF Developer (4 - 7), Cert. Adobe Instructor

– Writer in CFDJ, FAQU, Adobe DevCenter, CommunityMX, more

– Contributor to all three Ben Forta CF8 books

– Frequent speaker to user groups, conferences worldwide: cf.Objective, 
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– Frequent speaker to user groups, conferences worldwide: cf.Objective, 
CFUnited, webDU, webManiacs, Scotch on the Rocks, et al

– Run the Online ColdFusion Meetup (coldfusionmeetup.com)

– Living in Alpharetta, Georgia (north of Atlanta)



About Charlie Arehart
• Web home at www.carehart.org

– Hosts 200+ blog entries, 60+ articles, 70+ presentations, more

– UGTV: 
• Recorded presentations by over 100 CFUG speakers

– Tools/Resources to Consider: 
• 700+ tools/resources in 100+ categories

– Consulting: available for troubleshooting, tuning, training
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– Consulting: available for troubleshooting, tuning, training
• For as few as days, hours, or even minutes; remote or on-site



Solutions for 6, 7, and 8
• CF 8 Debugger, from Adobe

– Free with CF8
• Adobe ColdFusion 8 Extensions for Eclipse

– http://www.adobe.com/support/coldfusion/downloads.html#cfdevtools

– Works only on CF8

• FusionDebug, from Intergral 
– Commercial product (www.fusiondebug.com)
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– Commercial product (www.fusiondebug.com)

– Works on 6, 7, and 8

• Both are very similar
– And yet different

• Fundamentals of debugging are sameG



Introduction to Step Debugging
• Understanding interactive debugging

– What can it do for you?
• Step through code line-by-line (where needed)

• View variables, in all scopes, at that point

• Watch particular expressions, to observe changes

• Even change variables on the fly during execution
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• And more

• Both based on Eclipse
– But don’t let that scare you!

– Even if using DW, HS, use Eclipse just for debugging



Debugger Demos
• Let’s see them in action
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Demoed Features
• Set breakpoints, stepped through code

– Viewed variables,  watched expressions

• Showed simple CFML code (CF Example Apps)
– Showed query data in variables pane

• Showed CFC-based code
– Showed scopes available in CFC methods (var and this scopes)

– Showed how stack is interactive 
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• click to jump to lines in chain above current instruction

• Showed debugging Flex, Ajax apps
– Could also debug web svcs, Application.cfc, gateways, scheduled tasks

• Showed debugging inside CFSCRIPT
– Can also debug within CFOUTPUT, CFMAIL, CFSAVECONTENT, etc.



About Underlying Eclipse 
• What is Eclipse?

– Free Java-based editor, greatly extensible

– Also the basis of Flex Builder, CFEclipse
• can add debugger to those, or have separate Eclipse installation

• Why did Adobe, Intergral build these atop Eclipse?
– Built-in debugging features, just connected to CF

• Easy to install Eclipse plug-in (3.1, 3.2, 3.3)
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• Easy to install Eclipse plug-in (3.1, 3.2, 3.3)
– CF8 docs, articles explain how to install the plug-in

– FusionDebug offers an installer, and even a packaged version 
containing it and CFEclipse



Server Installation
• Both debuggers require minor modification of the CF server to be 

debugged

– Just a single line change in the jvm.config on the java.args line (see 
docs for details)

• Jvm.config located in C:\ColdFusion8\runtime\bin

• CF8 does it automatically via Admin checkbox

– Modifies the file and enables the feature after restart
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– Modifies the file and enables the feature after restart

– Note: in multiserver, requires manual editing

• Jvm.config for multiserver in C:\JRun4\bin

• FusionDebug offers installation wizard

– Modifies the file and enables the feature after restart



CF8 Debugger Relies on RDS
• In order to use the CF8 debugger, you must have enabled RDS during 

installation of CF
– If you did not, you need to enable it

• See http://www.adobe.com/go/tn_17276

– You then need to know the RDS password defined for your server (in the CF 
Admin)
• Or take advantage of the new multiple RDS user feature in the Security section of the 

ADMIN

– You will use this RDS password (or username/password) in the CF8 Eclipse 
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– You will use this RDS password (or username/password) in the CF8 Eclipse 
debugger setup steps
• Window>Preferences>ColdFusion>RDS configuration

• Documentation shared later offers more details

– Can test RDS setup in RDS Dataview/Fileview features also enabled in Adobe 
Eclipse extensions
• Window>Show View>Other>RDS FileView/DataView



Benefits Over CFDUMP/CFOUTPUT
• Can debug when a CFOUTPUT/CFDUMP may not be possible 

– What are some examples?
• CFCOMPONENT/CFFUNCTION OUTPUT=false
• CFSILENT
• When generating non-HTML output

– Flex/Flash, Flash Remoting, Ajax, web services clients, etc

• Debugging Application.cfc, event gateways, scheduled tasks
• Ever forget to remove debugging output?
• And a dozen other reasons
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• And a dozen other reasons
– See more details on all these at:

• http://carehart.org/blog/client/index.cfm/2006/9/7/fusiondebug_part2_why_us
e_versus_cfdump

– And that’s not even all of them
• More at http://www.fusion-reactor.com/fd/about.cfm



Similarities and Differences
• CF Admin setting for “timeout requests in x seconds” will affect 

debugging

– In FD, halts request 

– In CF8, generates timeout popup error in CF8 debugger

– In either case, either disable or increase the value in Admin

• Or use CFSETTING RequestTimeout=“xx” on pages being debugged

• Viewing generated HTML output

13

• Viewing generated HTML output

– CF8 debugger offers window to view that

• Window>Show View>Other>Debug Output Buffer

– FD does not, but can see it using Expressions window to show

• getPageContext().getCFOutput().getString()



Similarities and Differences (cont.)
• Breaking on run-time exceptions

– CF8 debugger can be configured to break on exceptions
• window>preferences>coldfusion>debug settings

• Will stop on most (not all) error (pops up window in debugger, error 
shown to user when done debugging)

• Even stops and shows pages you were not debugging

• Note that it also stops on code that throws errors
– Could be a negative in some code 
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– Could be a negative in some code 

• Note there’s a fix related to this in the new CF8 Cumulative Hot Fix
– http://www.adobe.com/go/kb402466

– FD does not stop on errors (debugging stops, error shown to 
user)



Similarities and Differences (cont.)
• Both debuggers permit debugging remote servers

• Debugging against a central server (test, production)
– FD: Multiple users requesting debugged page, all debugged

– CF8: Only first requesting user of a page will be debugged

– FD: Multiple developers can’t debug on one server (fine for 
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– FD: Multiple developers can’t debug on one server (fine for 
development)

– CF8: Multiple developers can debug on one server (could do in 
test)

• RDS security controls who is allowed to access debugger



Similarities and Differences (cont.)
• Ability to control variables shown

– CF8: selectable via window>preferences>coldfusion>debug settings>Debugger 
Scopes

– FD: just shows all variables

• Ability to set variables on the fly
– FD: While stepping, highlight variable, right-click, choose "Set Variable“, enter 

new value

– CF8: In either the Variables or Expressions panes, right-click and choose 
“Change Value”
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“Change Value”

• Ability to set watch expressions from code
– FD: While stepping, highlight variable, right-click, choose “Watch Expression“, 

enter varname; 
• or right-click in Expressions window and choose “Add watch expression”

– CF8: can only add via Expressions window



Things That Affect Both
• If file edited outside of Eclipse, breakpoints won’t move (affects both)

– May end up on line that keeps breakpoint from firing

• Can disable debugging temporarily

– “Disable checkpoints” option in Eclipse

– “stop debugging” button in CF8 Admin (for CF8 debugger)

• If Debugger installed but not visible

– use Window>Open Perspective>Other>Debug
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• If Navigator pane not visible

– use Window>Show View>Other>General>Navigator

• If Expressions tab not visible

– use Window>Show View>Other>Debug>Expressions



Tips and Traps
• Some CF8 Debugger tips and traps 

– No need to create mappings if Eclipse and CF on same machine

• Run>Debug>ColdFusion Application>yourconfig

• Otherwise, use “add mapping” there indicating both Eclipse and CF 
path

– Must enable Debugging via CF Admin console

• “allow line debugging” checkbox 
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• “allow line debugging” checkbox 



Tips and Traps (cont.)
• Some CF8 Debugger tips and traps (cont.)

– Favor Step-over to Step-Into
• Will step into tags like CFDUMP, CFSAVECONTENT, etc, which 
actually are CFM files
– cfusion\wwwroot\WEB-INF\cftags

• Gets error in CF8 debugger, but not in FD

– In multiserver edition
• Must edit jvm.config by hand
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• Must edit jvm.config by hand

• Also, consider creating unique config for cf instance (rather than at 
jrun4 level), otherwise CF may not start in some situations
– http://mkruger.cfwebtools.com/index.cfm/2006/4/17/multiserver

– http://www.doughughes.net/index.cfm?event=viewEntry&entryId=244



Tips and Traps (cont.)
• Some FD tips and traps

– Note that FusionDebug was updated to 2.0 in Feb 
2007, and 2.01 in May 2007

– Other tips, tricks, and traps:
• http://www.fusion-reactor.com/fd/tipsandtricks.cfm

• http://carehart.org/blog/client/index.cfm/2006/10/2/fusiondebu
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• http://carehart.org/blog/client/index.cfm/2006/10/2/fusiondebu
g_part4_tips_and_traps



Tricks
• Available shortcuts in Eclipse

– Breakpoint: ctrl-shift-b

– Step into/over/return/resume: f5/f6/f7/f8

• Commands also available on “run” menu

– Double-click on stack trace line/breakpoints list

• Opens file at that line

• Find command in Variables, Expressions panes

– Ctrl-f, or right-click+find
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– Ctrl-f, or right-click+find

– Available wildcards: ? And *

• Can copy variable/vals to clipboard with “Copy variables”

• Can “group” breakpoints, by file/project, or “working sets”

• Can export/import breakpoints



Learning More
• CF8 Debugger

– Documentation: CF8 ColdFusion Developer’s Guide

• http://livedocs.adobe.com/coldfusion/8/htmldocs/usingdebugger_1.h
tml

– About the ColdFusion Debugger

– Installing and uninstalling the ColdFusion Debugger

– Setting up ColdFusion to use the Debugger
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– Setting up ColdFusion to use the Debugger

– About the Debug perspective

– Using the ColdFusion Debugger

– Viewing ColdFusion log files

• http://livedocs.adobe.com/coldfusion/8/htmldocs/help.html?content=
basiconfig_19.html



Learning More (cont.)
• FusionDebug 

– Documentation (very good) available online
• www.Fusiondebug.com

• User guide walks through configuration of the CF Server, 
Eclipse, and use of FusionDebug

– Several Captivate demos
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– Several Captivate demos
• http://www.fusion-reactor.com/fd/demos.cfm



Learning More (cont.)
• Other resources on CF8 Debugger

– My chapter in ColdFusion 8 Web Application Construction Kit 
Volume 2: Application Development

• "Using the CF8 Debugger“ (25 pages)

• Available online

– http://www.forta.com/books/0321515463/CFWACK8-2-EChapters.pdf

– My FusionAuthority Quarterly Update article in CF8 Special 
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– My FusionAuthority Quarterly Update article in CF8 Special 
Edition

• “The ColdFusion 8 Debugger Explained: Interactive Step Debugging 
for ColdFusion 8”



Learning More (cont.)
• Other resources on CF8 Debugger (cont.)

– “Using the ColdFusion 8 step-through debugger for Eclipse”, 
Brian Szoszorek

• http://www.adobe.com/devnet/coldfusion/articles/debugger.html

– “Getting Started With The ColdFusion Debugger”, Ben Forta

• http://www.forta.com/blog/index.cfm/2007/5/30/CF8-Debugger-
Getting-Started
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Getting-Started

– ColdFusion 8 Debugger Resources and Tips

• http://www.thecrumb.com/2007/08/31/coldfusion-8-debugger-
resources-and-tips/



Learning More (cont.)
• Other resources on FusionDebug

– September 2006 CFDJ has 2 FD articles:
• “Taking a First Look at FusionDebug”, Jeff Houser

– http://coldfusion.sys-con.com/read/289634.htm

• “FusionDebug Tips, Tricks, and Traps”, Charlie Arehart
– http://coldfusion.sys-con.com/read/289652.htm

– “FusionDebug Explained: Interactive Step Debugging for CFML”, 
Charlie Arehart
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• http://www.fusionauthority.com/quarterly/

– FusionDebug series by Chaz Chumley
• http://www.communitymx.com

– I’ve done a series of blog entries
• http://carehart.org/blog/client/index.cfm/fusiondebug



FAQs
• Does either work with CF4 or 5?

– No, both are specific to CFMX

– FusionDebug runs on 6, 7, and 8

– CF8 debugger runs only 8

• Do they run on Linux? OS X? other platform
– Yes, they run on any platform that runs Eclipse 

– and can debug any server that runs ColdFusion

• Do they work with BlueDragon? Railo? Smith?
– Not currently. Intergral having discussions w/ Railo
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– CF8 debugger will of course not work with them

– But you could install free Dev edition of CFMX and debug against that

• How much do they cost?
– CF8 Debugger: Free

– FusionDebug: starts at $99, $249; see 
• http://www.fusion-reactor.com/fd/buy.cfm



FAQs (cont.)
• Do they support debugging Javascript? Actionscript? 
Java?
– No, that’s left to other debuggers

– Eclipse already can debug Java, and FlexBuilder can debug 
ActionScript

– Other tools offer Javascript debugging inside Eclipse
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• JavaScript Eclipse Debugger Plug-ins:

– http://www.aptana.com/

– http://www.myeclipseide.com/index.php?module=htmlpages&func=displ
ay&pid=270#jsdebug



FAQs (cont.)
• Can you use install FD and CF8 debugger in same 
Eclipse instance?
– Yes

• Can they both debug the same CF8 server?
– Yes, but if you debug a CF8 server with the CF8 debugger first, 
you’ll get an error in Eclipse
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you’ll get an error in Eclipse

• Need to “stop” CF8 debugger (in CF Admin) before trying to debug 
it with FD

• See Debugging & Logging>Debugger Settings>Stop Debugging 
Server

• Next request from CF8 debugger will restart it



FAQs (cont.)
• How do I get support?

– CF Support forums (General)
• http://www.adobe.com/cfusion/webforums/forum/index.cfm?f
orumid=1

– FusionDebug mailing list/forum
• http://groups.google.com/group/fusiondebug
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• http://groups.google.com/group/fusiondebug

• New FusionSupport Online knowledge base

– http://www.fusion-reactor.com/fd/support.cfm

• Intergral offers free and purchased email and remote support

– support@fusion-reactor.com



Conclusion
• Great solution, finally, for CFML debugging

– Whether on 6, 7, or 8

• Yes, they’re based on Eclipse
– But again, you can continue to use your favorite editor, and just use 

Eclipse for debugging

• Sure, FD costs money, but will pay for itself if you’ll benefit from 
debugging on 6, 7
– And has some differences from the CF8 debugger
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– And has some differences from the CF8 debugger

• Getting used to relying on debugger
– The challenge is simply remembering to use it!

– Try for yourself and see if it doesn’t help



Questions on presentation
• Charlie Arehart

– charlie@carehart.org

• I’d really appreciate your feedback
– http://carehart.org/feedback/

• Also available for setup and implementation consulting
– Also other developer productivity coaching, system admin and tuning 

support, and more

– Remote or on-site
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– Remote or on-site

– Again, for as little as days, hours, even minutes

– http://carehart.org/consulting/

• Finally, evaluationsG



Evaluations
• Title: Step Debugging in CF 6/7/8 with the CF8 
Debugger and FusionDebug

• ID: SA6A

• Speaker: Charlie Arehart
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